Introduction to mozilla
A Manual for First Time Users

by Kevin Quiggle
Version 1.1
Revision date February 17, 2004
Copyright

Introduction to Mozilla
A Manual for First Time Users
by
Kevin Quiggle

© Copyright February 17, 2004
Licensed under the Academic Free License version 2.0
http://www.opensource.org/licenses/afl-2.0.php

Attribution Rights: You must retain, in the Source Code of any Derivative Works that You create, all copyright, patent or trademark notices from the Source Code of the Original Work, as well as any notices of licensing and any descriptive text identified therein as an "Attribution Notice." You must cause the Source Code for any Derivative Works that You create to carry a prominent Attribution Notice reasonably calculated to inform recipients that You have modified the Original Work.

Additional information on this document, and access to electronic copies and source files, may be found at this location:
http://mozmanual.mozdev.org/index.html
About this Guide

This manual is a brief introduction to some of the most useful features and functions of Mozilla. Learning this short list of features will enable you to use the most powerful and useful capabilities of this software in a short time.

This manual is not an exhaustive list of all of the capabilities of this software. Mozilla is a powerful suite of applications with many capabilities and functions. Once you have become familiar with the general capabilities of Mozilla, you can learn additional features through the references given at the bottom of this page.

Mozilla is a suite of applications which includes these five components (this manual addresses primarily the first three):

- **Navigator (Web Browser)**
  This is the application used to view web pages. It is similar in function to Internet Explorer, but it includes many additional capabilities like tabbed browsing, popup blocking, and other features explained in this guide.

- **Mail and Newsgroups (Email client)**
  This application is used to send and receive email. It includes a variety of new capabilities, as outlined in this guide.

- **Address Book**
  The Address Book component enables you to maintain multiple address books, and is fully integrated with the email client. The address book is also integrated with departmental and other directories; this enables address lookup of any email address in any of the available directories. This application is discussed in this guide only in the context of using the email client.

- **Composer (Web Page Editor)**
  This application is used to create or edit web pages. It is also the application used internally by the email application for composing messages. This guide does not discuss Composer, except in the context of using the email client.

- **ChatZilla**
  This application is an IRC (Internet Relay Chat) client. This application is not permitted in some businesses, and this guide does not address its use.

Additional information and news about Mozilla can be found here:

- Mozilla web site: http://www.mozilla.org
- In the built in Help files (select Help > Help Contents from the menu bar)

See also Appendix 6.1 for additional sources.
What is Mozilla?
Mozilla is the successor to the Netscape web browser and email software; it is somewhat similar to Internet Explorer, but more powerful, more feature rich, and more customizable.

Some excerpts from the www.mozilla.org web pages (see www.mozilla.org/why/users.html) help explain why this is so:

The Mozilla suite of applications has plenty of features to make browsing and email easier, faster and more convenient. Once you've surfed the web using Mozilla's popup blocking and friendly Sidebar, or read your email in peace with Mozilla junk mail controls and the comfort of knowing you're not susceptible to email viruses, you'll never be satisfied with anything else.

And for the power user, Mozilla provides sophisticated control over your browsing experience. With Mozilla's advanced JavaScript controls, tabbed browsing, image blocking, multiple mail accounts, privacy management, themes and extensions, advanced users will find everything they need to optimize the Web experience. For customizing your entire internet experience, Mozilla can't be beat.

Mozilla is a suite of applications including a Web browser, email client, HTML composer, IRC chat client, and a set of Web developer tools. Mozilla is fast, feature full, secure and customizable. Mozilla supports everything needed for a great Web browsing experience. This includes the ability to handle all of the agreed upon standards (W3C, ECMA, etc.), as well as almost all of the emerging and draft standards

In addition to supporting the Web standards and common proprietary plug-ins, Mozilla has great support for the millions of non-standard Web pages. Mozilla's "quirks" mode and "almost standards" mode ensure that even buggy Web pages display quickly and correctly. For more information on Mozilla and supporting Web standards take a look at http://www.mozilla.org/why Mozilla offers a host of features to make browsing easier, faster and more convenient.
Notes:

Illustrations
The Mozilla browser window illustrations in this guide have been reduced from full-screen windows to enable them to better fit the page. For this reason, the windows will look more cramped and cluttered than in actual use (where you are more likely to use a full screen window).

Appearance
Mozilla allows the user to choose the appearance of the browser by selecting his or her own theme. The theme used for illustrations in this manual is the Classic theme.

Menu Conventions
Menu selections are shown in italics. When you are required to select a menu, and then select choices from that menu or subsequent sub-menus, this will be shown as follows:

Edit > Preferences > Mail & Newsgroups > Windows

This means:
1. Select the Edit menu
2. Select Preferences from the Edit menu list
3. Select Mail & Newsgroups from the Preferences sub-menu
4. Select Windows from the Mail & Newsgroups sub-list

Key Combinations
Some functions may be accessed by hitting multiple keys at the same time; this will be indicated as follows:

- **Ctrl L** Hit the **CTRL** and **L** keys at the same time
- **Ctrl Shift W** Hit the **CTRL SHIFT** and **W** keys at the same time

Free Mozilla Software
Want to use Mozilla at home on your PC? Free downloads of Mozilla software can be found at [www.mozilla.org](http://www.mozilla.org) (or you may order it on CD). The free software is fully functional “open source” software. DecisionOne telephone support is also available.
# Table of Contents

*Copyright*: ii
*About this Guide*: iii
*What is Mozilla?*: iv
*Notes*: v

**Section 1 :: Navigator (Browser) Features**
1.1 - Browser screen – naming the parts................................. 1
1.2 - Help.................................................................................. 3
1.3 - Tabbed Browsing................................................................. 4
1.4 - Searching......................................................................... 6
1.5 - Print Preview.................................................................... 7
1.6 - Image Management........................................................... 8
1.7 - Popup Blocking................................................................. 9
1.8 - Bookmarks and Personal Toolbar.................................... 10
1.9 - Sidebar............................................................................. 11
1.10 - Text Re-Sizing................................................................. 12
1.11 - Themes............................................................................ 13
1.12 - Find as you type and caret browsing............................ 14
1.13 - Form Manager................................................................. 15
1.14 - Password Manager......................................................... 16
1.15 - Custom Keywords......................................................... 17

**Section 2 :: Mail**................................................................. 20
2.1 - Mail window – naming the parts................................... 20
2.2 - Message Composition..................................................... 22
2.3 - Spellchecker................................................................. 24
2.4 - Message Views.............................................................. 25
2.5 - Label.............................................................................. 26
2.6 - Message Folders........................................................... 27
2.7 - Filters................................................................. 28
2.8 - Junk Mail Controls......................................................... 29

**Section 3 :: Address Book**............................................... 33

**Section 4 :: Composer**......................................................... 36

**Section 5 :: IRC Chat (Chatzilla)**........................................... 37

**Section 6 :: Appendix**......................................................... 38
6.1 - Information About Mozilla..................................... 38
6.2 - Bookmarklets........................................................... 39
6.3 - Extensions................................................................. 39
6.4 - How Cool are Custom Keywords?........................ 40
6.5 - Keyboard Shortcuts................................................. 41
Section 1 :: Navigator (Browser) Features

1.1 - BROWSER SCREEN – NAMING THE PARTS

To better understand this guide, it will be helpful to know the names of the various parts that make up the Mozilla browser window. The figure below shows a browser window with labels for the various section names.

![Browser Window Components](image)

*Figure 1: A sample browser window showing the names of the browser components.*

See the next page for a simplified view of the figure above.
Navigator (Browser) Features

The figure below shows a schematic view of the browser window with labels for the various section names.

Figure 2: Schematic view of the browser window, with labeled parts.
1.2 - Help

Mozilla includes extensive built-in help information. From the Menu Bar, select Help > Help Contents, to access the built-in help files. The illustration below shows how to access the help files, and what the help file display (“Mozilla Help”) will look like after you select Help Contents.

TIPS:

Use the Print button in Help to print an entire help page (or make a text selection first to print only the selected section).
1.3 - Tabbed Browsing

Tabbed browsing enables you to open multiple web pages at the same time, in a single browser window, using folder-like “tabs” (see Figure 1). A group of tabs can also be bookmarked, enabling all of the bookmarked tabs to be re-opened at one time.

Figure 4: Example browser window showing three tabs.

TIPS!:

- Right-click on a link and select Open Link in New Tab to open a link in a tab.
- Type Ctrl + T to open a new tab.
- Right-click on a tab to get options for opening or closing tabs.
- Click the New Tab button to open a new tab (see figure above).
- Click the Close Tab button to close the right-most tab (see figure above).
• The *Tab Bar* may not display if you have only one web page open (you can customize this option: On the *Menu Toolbar* select *Edit > Preferences > Navigator > Tabbed Browsing* and choose your preferred settings).

• Drag and drop a link to a tab to open the link in that tab.

• Drag and drop a link to an “open” space on the *Tab Bar* to open a link in a new tab (Note: This even works for Internet locations shown as text, even if they are not displayed as links!).
1.4 - **Searching**

Mozilla offers numerous options for searching. First, you can set your personal preferences to select the Internet search engine you prefer (in this guide, the selected preference is Google).

![Image of Google search interface](image)

**Figure 5:** Search example showing Sidebar and Google search results.

The Internet search result shown can be obtained in any of three ways:

1. Type the search term in the location bar and click on the **Search** button.
2. Type the search term in the Sidebar and click on the Sidebar **Search** button.
3. Select a word or phrase with the mouse, right-click, and select **Web Search for** ... from the drop down menu (note, this option will open a new browser window with the search results from your preferred search engine).

**TIPS!**:

- Type `Ctrl` + `L` to put the cursor in the **Location bar**.
- You can search your personal bookmarks (see **Bookmarks** section).
- You can search for text or links on a displayed web page.
1.5 - Print Preview

The Print Preview option shows you what a browser page will look like when it is printed. You can access print preview in two ways, as shown below. The print preview option not only enables you to preview printed web pages, it also allows you to select portrait or landscape format, set margins, and select other print options. When you select the print option, you can further select the page range to print, number of copies, and printer properties.

**TIP!:**

Select print preview in these two ways:

- Clicking on the Print menu selector (the button marked with a triangle shape, next to the print button); this will open a drop-down menu with a Print Preview option.
- Select File > Print Preview from the Menu Bar.
1.6 - **Image Management**

Mozilla offers a number of features to improve the viewing of images. These include:

- Popup blocking (According to recent polls, popups are the #1 Internet annoyance).
- Block images (block images from third-party sites, block images for selected sites, block images in email).
- Control looping (repeating over and over) of animated images.
- Resize images to fit the screen.

Further, by right clicking on an image, you can save an image as a file, send it as an email attachment, and perform other useful functions.

**TIP!**: Mozilla can automatically resize large images to fit the browser window. When this occurs, you can see the full size image by clicking on the image. When you put the mouse pointer over the image, it will turn into a “magnifying glass” icon if the image has been resized.
1.7 - **Popup Blocking**

Popups are small windows that display automatically, and without your permission. These windows may display on top of the web page you are viewing (popups), or below the web page (pop-unders). Pop-ups are often advertising, and may be annoying or intrusive; Mozilla therefore enables you to block unwanted popups (this includes pop-unders) from displaying.

In some cases, web sites (or web-enabled applications) will use popups as part of their function. In these cases, Mozilla popup management enables you to selectively permit popups to display.

**TIPS!:**

- Look for the *Popup Control Icon* to signal you if a popup has been blocked.
- If a web page link looks like it is not working, try selecting the *Popup Manager* as shown above, and selecting “allow popups from this site;” then click the link again to see if it works.
- Mozilla can also *play a sound* to signal you when a popup is blocked (on the *Menu Bar*, select *Edit > Preferences > Privacy & Security > Popup Windows*).
1.8 - **Bookmarks and Personal Toolbar**

Bookmarks are your personal shortcuts to web sites you frequently visit. You can access or manage your bookmarks in several ways:

1. Select *Bookmarks* on the *Menu Bar*.
   - This option will also give you a menu choice to bookmark a group of tabs.
2. Drag a link from the *Location Bar* to your Bookmarks folder.
4. Right click on a web page to get a menu option to bookmark that page.

See also the *Custom Keywords* section for more information on using bookmarks.

---

**TIP!:**

You can create sub-folders in your bookmarks folder to help organize your bookmarks.
1.9 - Sidebar

The Sidebar is a section of your browser which you can customize to add items you use frequently. To add or remove items from your personal Sidebar, click on the Tabs button on the Sidebar.

The example shown in the above illustration shows that a MapQuest item has been added to the sidebar to enable quick access to maps or driving directions.

**TIPS!:**
- Type [F9] to open or close the Sidebar.
- Click the X button (see figure above) to close the Sidebar.
- Click on a Sidebar tab to access that particular item.
1.10 - **Text Re-Sizing**

A handy feature of Mozilla is the ability to easily resize the text in a browser window:

- Type `Ctrl` + to make text larger.
- Type `Ctrl` - to make text smaller.
- Type `Ctrl` 0 to make text original size.

The illustration below shows two browser windows. The top window shows text in the original size. The bottom window shows text that has been re-sized to make it larger. Enlarging text can make it much easier to read text pages with small type.

![Figure 11: Original size text (left) resized to make it larger (right).](image-url)
1.11 - Themes

Mozilla themes (similar to skins) are “window dressing” which give Mozilla a look suited to your personal style. As the figure below shows, your theme selection determines the style of the browser menus, buttons, and other features, but does not alter the way a particular web page displays. Mozilla has two standard themes, and you can download many more themes from the Internet.

**Figure 12:** Browser showing three different themes: Classic, Modern, and Orbit Retro.

**TIPS!**

- To change themes: On the Menu Toolbar select View > Apply Theme (pick the new theme you want).
- Get more themes: On the Menu Toolbar select View > Apply Theme > Get New Themes.
Mozilla offers some very useful features to enable you to find information within a displayed web page. These features are selected as follows:

/ [Forward slash] Find text as you type

Example: Type /mozilla to find occurrences of the word “mozilla” in a web page.

- Type F3 to find additional matches after the first match.
- Type Shift F3 to find previous matches.

' [Single quote] Find links as you type

Example: Type 'mozilla to find links containing the word “mozilla” in a web page.

- Type F3 to find additional matches after the first match.
- Type Shift F3 to find previous matches.

F7 [F7 function key] Caret browsing

This will display a “caret” or position symbol (like this: | ) on the web page. Use the arrow keys to move the caret; hold down the shift key to select text. This enables you to select text on a web page without using the mouse ("keyboard only" text selection).
1.13 - **Form Manager**

The *Form Manager* is a very useful feature which allows you to save information you have typed into a web page form, so you can use it again later without having to re-type the same information. The *Form Manager* is accessed by selecting **Tools** on the **Menu Bar** as shown below.

![Figure 13: Selecting the Form Manager (browser window shows web form).](image)

**TIP!:**

Use the **Help** option on the **Menu Bar** to get detailed information on using the *Form Manager.*
1.14 - **PASSWORD MANAGER**

The **Password Manager** function will activate automatically whenever you access a web page that asks you to enter your name and password. When you “submit” the page to send this information, the **Password Manager** will ask you, "Do you want Password Manager to remember this logon?" If you answer yes, then your name and password will be saved – the next time you access that web page, the values will be filled in for you automatically.

**TIPS!:**

- Use the **Help** option on the **Menu Bar** to get important information about saving passwords, and using a **master password** to secure your password information.
- Modify your saved password settings using the **Password Manager** as noted above.
 Custome Keywords are a powerful feature which enables you to create your own personal keywords which you can type into the location bar for quick access to your favorite sites. Here is how you can use this feature (this assumes that you have already created a bookmark for the site you are interested in; in this example we will use Google as the bookmarked site):

First: Select Bookmarks – Manage Bookmarks. This will open the Bookmark Manager.

Figure 15: Selecting the Manage Bookmarks function from the Menu Bar.

Continued on next page...
Second: Select a bookmark in the *Bookmark Manager* menu by right-clicking on bookmark. Select *Properties* in the drop down menu to access the *Properties Menu*.

*Figure 16*: Accessing the *Properties Menu* for a selected bookmark.

Continued on next page...
Third: Type a keyword of your choosing into the **Keyword** box in the **Properties Menu**. In the example below, the keyword has been set to **google**, but you can choose any word you like. Based on this example, you can now type **google** into the **Location Bar** to immediately access the Google website.

![Properties Menu for the Google bookmark. The keyword has been set to “google”](image)

**Figure 17:** The **Properties Menu** for the Google bookmark. The keyword has been set to “google”

**TIPS!**

- Use the **Help** option on the **Menu Bar** to get more information on using and managing bookmarks.

- See the article *How Cool are Custom Keywords?* in the appendix (Section 6.4) of this manual for advanced options for using custom keywords.
Section 2 :: Mail

2.1 - Mail Window – Naming the Parts

The mail window (see figure below) consists of three panes:

1. Sidebar – Displays a list of message folders (and multiple email accounts, if you have more than one)
3. Message pane - Displays selected message (select message from message list).

Figure 18: Example of Mozilla mail window.

TIP!:
- Click on a column heading of the message list (Subject, Sender, Date, Priority, etc.) to sort by that heading; click again to reverse the sort order.
Mail Window Layout

Mozilla also lets you select the type of mail window layout you would like. From the Menu Bar, select Edit > Preferences > Mail & Newsgroups > Windows. You will then have a choice of either of the two mail window layouts shown below (Note: For the change to take effect, you must close and then re-open the message window).

![Mail Window Layout Diagram]

**TIP!**:
- Click and drag on the bar dividing two panes to re-size a pane.

Figure 19: Mail Window layout options.
2.2 - *Message Composition*

**Message Composition Window**

To create a new mail message, click on the *Compose* button; this will create a *message composition window* as shown below.

*TIPS!:

- Use message composition to set **bold**, *italic*, and *underlined* text, for font and text size selection, indenting, bulleted and numbered lists, and to insert objects (images, tables, links, line, anchor).
- Drag and drop files to the *Attachments Area* to attach them to a message.
- Double-click the *Attachments Area* to get an attachment menu.
Smileys

Smileys are a popular feature in email messages (the name comes from “smiley face”). Smileys are graphical “punctuation marks” which you can insert in your email messages to indicate various emotions (smile, frown, wink, etc.). Mozilla makes it easy to insert smileys from a menu on the Formatting Toolbar.

Smileys are sometimes entered as “sideways text” (for example, “smile” would be entered like this:

:-) [Tilt your head to the left to see the “face”]

**TIP!:

- When you receive a message containing a “text smiley,” Mozilla Mail will automatically convert it to the corresponding graphical symbol.
2.3 - SPELLCHECKER

When you are sending email, you can use the built in Spell function to check the spelling in your message.

If the spell checker finds a misspelled word, it will typically suggest corrections. You can double-click on a suggestion to choose it, or if there is no acceptable suggestion, you can simply type in a correction. You can also add words, acronyms, etc. to your personal dictionary; words matching entries in your personal dictionary will be accepted as correct. Warning: The spell checker does not check spelling in the Subject box!
2.4 - Message Views

Message views help you quickly locate messages in your Inbox (or other folders). There are two basic view options:

1. View category – select a list of messages by a specific category (see figure below). There are twelve pre-defined categories, and you can also create your own custom categories.

2. Subject or sender – type a name or word into the indicated box, and only messages with a matching sender or subject will be listed. Click on the clear button (to the right of the box) to clear the box.

You can also use combinations of the two options, selecting both by view category and by matching text.

Figure 23: The message View drop-down menu.
2.5 - Label

The label function lets you label (color code) a message based on one of five different categories. You can do this manually by right clicking on a message and selecting the Label option and preferred category as shown below, or automatically by creating a message filter as explained in the section on Filters (Section 2.7).

Figure 24: Right click on a message to label it. In this example the second message has already been labeled as “Important.”

**TIP!**

You can change the names and colors of the label categories by changing your Preferences (on the Menu Bar, select Edit > Preferences > Mail & Newsgroups > Labels).
2.6 - MESSAGE FOLDERS

Message folders are like file folders for your messages. Use message folders to store and organize messages you do not want to keep in your Inbox. You can create as many folders as you need to organize your messages, including folders within folders (sub-folders).

**TIPS!**

- To file a message to a message folder:
  - Drag and drop a message to a folder.
  - Select *File* from the *Menu Toolbar*.
  - Right-click on a message and select the *Move to* option

- Create no more than 5 – 10 general folders at the top level, with sub-folders for more detail (so you can see all high level folders in your sidebar).

- Corporate IMAP users: Avoid using *Local Folders* – creating your folders on the IMAP server will promote security and accessibility.

*Figure 25: Message folders are shown in the sidebar to the left of the message list.*
2.7 - Filters

Message filters can be created to help manage your email. For example, using filters you can automatically process new mail to file it, label it, delete it, change priority, flag it, or perform other actions. To access message filters, start the Mail application; on the Menu Bar, select Tools > Message filters... You will see something like the Message Filters menu shown below.

![Message Filters Menu](image)

*Figure 26: Message filter menu showing a filter called “Important stuff.”*

You can create as many filters as you like. The filters can be customized to select messages based on subject, sender, date, age of the message, and other criteria (and combinations of these).

**TIP!:
- To create filters, on the Menu Toolbar select Tools > Message Filters...
- Create a message filter to flag or label messages sent to you by key people in your organization.*
2.8 - **Junk Mail Controls**

Junk Mail Controls enable your email reader to automatically (almost) recognize and remove junk mail (also known as spam) from your email Inbox. It is “almost automatic” because a small amount of preparation is required; after you log in to your email account, do the following:

**First:** Enable junk mail controls.

**Second:** Train Mozilla to recognize junk mail.

**Third:** Maintenance to keep junk mail control current.

**First: Enable Junk Mail Controls**

From the Menu Bar, select **Tools > Junk Mail Controls**...

*Figure 27: Select Tools from the Menu Bar, then select Junk Mail Controls.*

Continued on next page . . .
Recommended settings for the *Junk Mail Controls* menu are shown below. Make sure the eight settings marked below are set. Now click on OK to save your settings.

![Junk Mail Controls Menu]

*TIP!:

Do not automatically move junk mail (see #3 above) until you have completed initial junk mail training (until then, you can manually delete real junk, and “un-flag” false positives). When you're satisfied that the training is working, go back and set the preference to automatically move junk mail to the junk folder.

*Continued on next page . . .*
Second: Train Mozilla to Recognize Junk Mail

Now you need to teach Mozilla to recognize messages you consider to be junk. You do this by clicking on the junk icon next to each message that you consider junk. In this way, Mozilla learns to recognize patterns that identify mail as junk. Initially, you may find that Mozilla will incorrectly identify a good message as junk; when this happens, simply click on the junk icon to flag the message as “not junk” (this will also help Mozilla learn the proper patterns).

When you first begin training Mozilla to recognize junk mail, you will need to check your junk mail folder to recover false positives (good messages marked as junk). When there are no more false positives (or very few), you will know that your junk mail controls have been properly trained. The training period typically takes a few days, but it may be shorter or longer depending upon how much mail you receive, and how much of it is junk.

![Figure 29: Message window showing one message flagged as junk.](image)

Continued on next page . . .
Third: Maintenance

Once your junk mail controls are working, you will need to continue to perform the following regular checks:

- Check your junk mail folder for **false positives**.
  - If you find legitimate mail marked as junk, click on the junk icon to mark it as good mail, and drag it to the Inbox folder.
- Mark any new junk messages in your Inbox as junk, to keep your junk mail controls up to date.

Unfortunately, it is not possible to just train your junk mail controls and then forget about them. This is because the junk mail senders are continually coming up with new tricks to get around the junk mail controls. In practice, however, you will find that the junk mail controls will catch most junk mail, with very few false positives.
Section 3 :: Address Book

The Mozilla Address Book stores email addresses for sending messages (and also stores other “people related” information like telephone numbers, addresses, and so on). Using the Address Book component you can do the following:

- Access your business (LDAP) directory.
- Maintain one or more personal address books.
- Create and maintain email distribution lists.

You can get to the Address Book by any of these methods:

- Select the Address Book icon on the Component Bar.
- On the Menu Bar, select Window > Address Book.
- Type Ctrl S
- Select Address while composing an email message.

Figure 30: Address Book menu.
Each *Address Book* entry is associated with an *address card*. Each card has three sections, or tabs, for recording information related to a particular entry.

**Figure 31:** The three sections of an *Address Book* card (Contact, Address, Other).

**TIP!**

When viewing an email message, you can right-click on an email address for an option to automatically add it to your address book.
The Address Book function is also available when you are composing (creating) a new email message. Simply select the Address Button in the message compose window (see figure below) to bring up an address search menu (Select Addresses in the figure below). Follow these easy steps to select addresses for your message:

1. Select the Address Book you want to search.
2. Enter a name to search for.
3. Select (highlight) from the name(s) listed.
4. Click on the type selector to add the address to your message.
5. Repeat steps 1 – 4 to select all desired addresses, then click OK.

Figure 32: Selecting addresses with the message composer Address Menu.
Section 4 :: Composer

Mozilla Composer is a like a word processor for web pages - you can create, edit, and publish your own web pages. You can add tables and pictures, change font styles, and easily perform other web page creation functions. Composer is also the “engine” used by email to compose a new message, so many of these same functions and capabilities are available for email message creation.

In keeping with the goal of this manual to provide information to business users of Mozilla primarily for Navigator, Mail and Address Book, this component will not be discussed further. However, if you are interested in learning more, use the Help option on the Menu Bar to view extensive information on this component.

![Figure 33: The Mozilla Composer window.](image)
Section 5 :: IRC Chat (Chatzilla)

This component is an IRC (Internet Relay Chat) client; chat software may be blocked or restricted in your business environment. In keeping with the primary goal of this manual to provide information to business users of Mozilla, this component will not be discussed further.

Note:
The current version of Mozilla help contains no information on this component. However, you can find extensive information on the Internet at this location:

   http://www.mozilla.org/projects/rt-messaging/chatzilla/
## Section 6 :: Appendix

### 6.1 - Information About Mozilla

A huge amount of information about Mozilla is available on the Internet. Here is a brief selection of some of the most useful web sites:

<table>
<thead>
<tr>
<th>Description</th>
<th>Website</th>
</tr>
</thead>
<tbody>
<tr>
<td>The home site for the Mozilla Foundation, and the main site for official Mozilla information.</td>
<td><a href="http://www.mozilla.org">http://www.mozilla.org</a></td>
</tr>
<tr>
<td>The “Mozilla Magazine” for news and discussion about Mozilla.</td>
<td><a href="http://mozillazine.org">http://mozillazine.org</a></td>
</tr>
<tr>
<td>Another Mozilla news source.</td>
<td><a href="http://mozillanews.org/">http://mozillanews.org/</a></td>
</tr>
<tr>
<td>Documentation for end users of Mozilla.</td>
<td><a href="http://www.mozilla.org/docs/end-user/">http://www.mozilla.org/docs/end-user/</a></td>
</tr>
<tr>
<td>The primary site for development projects related to Mozilla (Mozilla development efforts).</td>
<td><a href="http://www.mozdev.org">http://www.mozdev.org</a></td>
</tr>
</tbody>
</table>
Appendix

Additional capabilities can be added to Mozilla through the use of “add-ons.” A few of these are discussed briefly in this section – see the web site references for more detailed information.

6.2 - **BOOKMARKLETS**

*Bookmarklets* are free tools which extend the capabilities of your browser to improve search, navigation, and web page manipulation. Bookmarklets typically work like a bookmark, but instead of bookmarking a page, they bookmark a function (sort of like a simple macro in a word processor or spreadsheet).

**Reference site:** [http://www.squarefree.com/bookmarklets/](http://www.squarefree.com/bookmarklets/)

6.3 - **EXTENSIONS**

A Mozilla extension is software you can install to add new functions to your browser – this can include new function bars, new menus or menu items, and numerous other capabilities. Extensions essentially become a new part of your browser, and are included automatically on startup once you have added them.

**Reference site:** [http://extensionroom.mozdev.org/](http://extensionroom.mozdev.org/)
**6.4 - How Cool Are Custom Keywords?**

by Asa Dotzler

[The article below has been reprinted with the permission of the author. Some minor changes have been made to make the terminology consistent with the rest of this manual.]

So Mozilla Custom Keywords ROCK! Not just for making shorthand for bookmarks but also for searches and queries. Simple Custom keywords allow you to type a short string in the Location Bar and load its corresponding Bookmark URL. To set a keyword you must first create a bookmark for the URL. You can do this by visiting the site and using the Bookmark > Add Current Page (Ctrl D) or you can go to the Manage Bookmarks window (Ctrl B) and create a new bookmark with File > New Bookmark. After you have created the bookmark you can add a keyword to the bookmark in the Bookmark Properties window (Edit > Properties, Ctrl I, or context menu Properties). In the Bookmark Properties window simply add a short string to the Custom Keyword field. Now close that dialog and you can type the keyword in the location bar, hit enter and it will load that URL.

An example I have is the bookmark for www.mozilla.org to which I've added the keyword "m.o". So with that set I can type m.o in the Location Bar and it loads http://www.mozilla.org. Keywords combined with autocomplete in Mozilla I seldom type more than about three or four characters for all of the sites I regularly visit.

But that's just the beginning. Custom keywords can be used to create shortcuts for your favorite search engines too (the 'this ROCKS!' part). Here's how it works.

I'll use Bugzilla Bug Report lookup as an example.

- Bookmark http://bugzilla.mozilla.org/show_bug.cgi?id=%s (where the "%s" replaces the part of the URL that would be the bug number/unique part of the query string)
- Give the bookmark a keyword like "bug"
- Restart Mozilla (seems to be necessary on some but not others, not sure why).
- Now typing "bug 12345" in the addressbar will load that bug.

The keyword "bug" followed by a space and the bug number will load the URL "http://bugzilla.mozilla.org/show_bug.cgi?id=" with the bug number, "12345" appended to the end of it loading the bug.

Some other really cool examples:

- http://www.google.com/search?q=%s&btnG=Google+Search (I gave it the keyword "google")
- http://www.dictionary.com/cgi-bin/dict.pl?term=%s (I gave it the keyword "dict")
- http://climate/reports/incidenttemplate.cfm?bbid=%s (I gave it the keyword "talkback", note that this will only work inside the Netscape firewall)

There are probably other great uses for this, just try a query at your favorite search engine and look at the URL it generates. If you can replace your search string in that URL with "%s" you can probably make this work. Throw in a little javascript and it's off to the races :)
6.5 - **Keyboard Shortcuts**

The information in this section is taken (with some modification for print purposes) from the following web pages:

[http://www.mozilla.org/docs/end-user/moz_shortcuts.html](http://www.mozilla.org/docs/end-user/moz_shortcuts.html)

Topics in this section include the following:

- Using Shortcuts
- General Mozilla Shortcuts
- Navigator Shortcuts
- Mail & Newsgroups Shortcuts
- Composer Shortcuts
- Help Window Shortcuts

**Using Shortcuts**

This document uses the following format for listing shortcuts:

**Example**:

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td>Cmd+C</td>
<td>Ctrl+C</td>
</tr>
</tbody>
</table>

To perform a command, press the buttons listed together at the same time. For example, to copy in Windows, press Ctrl and C at the same time.

**Tip**: The plus sign (+) means that you must press two keys surrounding the plus sign at the same time. If there is more than one plus sign (such as Ctrl+Shift+C), it means that all three buttons surrounding the plus sign must be pressed at the same time.

**Abbreviations**:

- Ctrl = Control key
- Cmd = Command key on the Macintosh keyboard

**Note**: Some keyboard shortcuts perform different functions based on cursor location (“focus”). For example, if you press Home on Windows while viewing a web page, Mozilla will move to the top of the web page. However, if you press Home on Windows while the cursor is in a text field, the cursor will go to the beginning of the text field.

**Warning**: Other applications may set conflicting control key combinations, in which case using the keyboard shortcuts listed here may lead to unexpected results.
# General Mozilla Shortcuts

These shortcuts are available from all Mozilla windows:

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td>Cmd+C</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td>Cmd+V</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td>Cmd+X</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Close Window</td>
<td>Ctrl+W</td>
<td>Cmd+W</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Delete Next Word</td>
<td>Ctrl+Del</td>
<td>Ctrl+Del</td>
<td></td>
</tr>
<tr>
<td>Go Up One Page</td>
<td>Page Up</td>
<td>Page Up</td>
<td>Page Up</td>
</tr>
<tr>
<td>Go Down One Page</td>
<td>Page Down</td>
<td>Page Down</td>
<td>Page Down</td>
</tr>
<tr>
<td>Go Up One Line</td>
<td>Up Arrow</td>
<td>Up Arrow</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>Go Down One Line</td>
<td>Down Arrow</td>
<td>Down Arrow</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
<td>Cmd+Z</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Shift+Z</td>
<td>Cmd+Shift+Z</td>
<td>Ctrl+Shift+Z</td>
</tr>
<tr>
<td>Find</td>
<td>Ctrl+F</td>
<td>Cmd+F</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Find Again</td>
<td>Ctrl+G or F3</td>
<td>Cmd+G</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Find Links As You Type</td>
<td>' (apostrophe)</td>
<td>' (apostrophe)</td>
<td>' (apostrophe)</td>
</tr>
<tr>
<td>Find Text As You Type</td>
<td>/</td>
<td>/</td>
<td>/</td>
</tr>
<tr>
<td>Open search engine page</td>
<td>Ctrl+Shift+F</td>
<td>Cmd+Shift+F</td>
<td>Ctrl+Shift+F</td>
</tr>
<tr>
<td>Open Context Menu</td>
<td>Shift+F10</td>
<td>Ctrl+Space</td>
<td>Shift+F10</td>
</tr>
<tr>
<td>Open Main Menu</td>
<td>Alt or F10</td>
<td>(Mac OS X: Controlled through keyboard preference in Control Panel)</td>
<td>F10</td>
</tr>
<tr>
<td>Move to beginning of line (in text edit field)</td>
<td>Home</td>
<td>Cmd+Left Arrow</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Move to end of line (in text edit field)</td>
<td>End</td>
<td>Cmd+Right Arrow</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Exit Mozilla</td>
<td>Ctrl+Q</td>
<td>Cmd+Q</td>
<td>Ctrl+Q</td>
</tr>
<tr>
<td>Start Navigator</td>
<td>Ctrl+1</td>
<td>Cmd+1</td>
<td>Ctrl+1</td>
</tr>
<tr>
<td>Start Mail &amp; Newsgroups</td>
<td>Ctrl+2</td>
<td>Cmd+2</td>
<td>Ctrl+2</td>
</tr>
<tr>
<td>Start IRC Chat</td>
<td>Ctrl+3</td>
<td>Cmd+3</td>
<td>Ctrl+3</td>
</tr>
<tr>
<td>Start Composer</td>
<td>Ctrl+4</td>
<td>Cmd+4</td>
<td>Ctrl+4</td>
</tr>
<tr>
<td>Start Address Book</td>
<td>Ctrl+5</td>
<td>Cmd+5</td>
<td>Ctrl+5</td>
</tr>
</tbody>
</table>
**Appendix**

**Navigator Shortcuts**

These shortcuts are available from all Navigator windows.

**Bookmarks Shortcuts**

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Manage Bookmarks Window</td>
<td>Ctrl+B</td>
<td>Cmd+B</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Add Page to Bookmarks</td>
<td>Ctrl+D</td>
<td>Cmd+D</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>File Bookmark (to customize and file a page you are bookmarking)</td>
<td>Ctrl+Shift+D</td>
<td>Cmd+Shift+D</td>
<td>Ctrl+Shift+D</td>
</tr>
<tr>
<td>Bookmark Properties (for selected bookmark in Manage Bookmarks window)</td>
<td>Ctrl+I</td>
<td>Cmd+I</td>
<td>Ctrl+I</td>
</tr>
</tbody>
</table>

**Page Navigation Shortcuts**

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open History Window</td>
<td>Ctrl+H</td>
<td>Cmd+Shift+H</td>
<td>Ctrl+H</td>
</tr>
<tr>
<td>Reload</td>
<td>Ctrl+R</td>
<td>Cmd+R</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Force Reload (not from cache)</td>
<td>Ctrl+Shift+R</td>
<td>Cmd+Shift+R</td>
<td>Ctrl+Shift+R</td>
</tr>
<tr>
<td>Back</td>
<td>Alt+Left Arrow or Backspace</td>
<td>Cmd+Left Arrow</td>
<td>Alt+Left Arrow</td>
</tr>
<tr>
<td>Forward</td>
<td>Alt+Right Arrow</td>
<td>Cmd+Right Arrow</td>
<td>Alt+Right Arrow</td>
</tr>
<tr>
<td>Stop</td>
<td>Esc</td>
<td>Esc</td>
<td>Esc</td>
</tr>
<tr>
<td>Home</td>
<td>Alt+Home</td>
<td>Cmd+Home</td>
<td>Alt+Home</td>
</tr>
<tr>
<td>Go to Bottom of Page</td>
<td>End</td>
<td></td>
<td>End</td>
</tr>
<tr>
<td>Go to Top of Page</td>
<td>Home</td>
<td>Home</td>
<td>Home</td>
</tr>
<tr>
<td>Select All Text in Location Bar</td>
<td>Ctrl+L or Alt+D</td>
<td>Cmd+L</td>
<td>Ctrl+L or Alt+D</td>
</tr>
<tr>
<td>Open Web Page Location</td>
<td>Ctrl+Shift+L</td>
<td>Cmd+Shift+L</td>
<td>Ctrl+Shift+L</td>
</tr>
<tr>
<td>Open Selected Link in a Web Page</td>
<td>Enter</td>
<td>Return</td>
<td>Enter</td>
</tr>
<tr>
<td>Exit Mozilla</td>
<td>Ctrl+Q</td>
<td>Cmd+Q</td>
<td>Ctrl+Q</td>
</tr>
</tbody>
</table>
### Move to Next Frame (in web pages using frames)

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to Next Frame</td>
<td>F6</td>
<td>Ctrl+Tab or F6 (if F6 is not programmed for another command)</td>
<td>F6</td>
</tr>
</tbody>
</table>

### Move to Previous Frame (in web pages using frames)

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to Previous Frame</td>
<td>Shift+F6</td>
<td>Ctrl+Shift+Tab or Shift+F6 (if F6 is not programmed for another command)</td>
<td>Shift+F6</td>
</tr>
</tbody>
</table>

### New Navigator Window

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Navigator Window</td>
<td>Ctrl+N</td>
<td>Cmd+N</td>
<td>Ctrl+N</td>
</tr>
</tbody>
</table>

### Move to Next/Previous Link or Form Element in a Web Page

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to Next/Previous Link</td>
<td>Tab/Shift+Tab</td>
<td>Tab/Shift+Tab</td>
<td>Tab/Shift+Tab</td>
</tr>
</tbody>
</table>

### Open File

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open File</td>
<td>Ctrl+O</td>
<td>Cmd+O</td>
<td>Ctrl+O</td>
</tr>
</tbody>
</table>

### Close Window

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close Window</td>
<td>Ctrl+W</td>
<td>Cmd+W</td>
<td>Ctrl+W</td>
</tr>
</tbody>
</table>

### Save Page As

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Page As</td>
<td>Ctrl+S</td>
<td>Cmd+S</td>
<td>Ctrl+S</td>
</tr>
</tbody>
</table>

### Save Linked Page (when a link is selected)

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Linked Page (when a link is selected)</td>
<td>Shift+Enter</td>
<td>Option+Enter</td>
<td>Shift+Enter</td>
</tr>
</tbody>
</table>

### Print Page

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print Page</td>
<td>Ctrl+P</td>
<td>Cmd+P</td>
<td>Ctrl+P</td>
</tr>
</tbody>
</table>

### Go Up One Page

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go Up One Page</td>
<td>Page Up/Shift+Space</td>
<td>Page Up/Shift+Space</td>
<td>Page Up/Shift+Space</td>
</tr>
</tbody>
</table>

### Go Down One Page

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go Down One Page</td>
<td>Page Down/Space</td>
<td>Page Down/Space</td>
<td>Page Down/Space</td>
</tr>
</tbody>
</table>

### Go Up One Line

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go Up One Line</td>
<td>Up Arrow</td>
<td>Up Arrow</td>
<td>Up Arrow</td>
</tr>
</tbody>
</table>

### Go Down One Line

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go Down One Line</td>
<td>Down Arrow</td>
<td>Down Arrow</td>
<td>Down Arrow</td>
</tr>
</tbody>
</table>

### Turn on/off Caret Mode

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Turn on/off Caret Mode</td>
<td>F7</td>
<td>F7 (if F7 is not programmed for another command)</td>
<td>F7</td>
</tr>
</tbody>
</table>

## Page Viewing Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Screen (toggle)</td>
<td>F11</td>
<td>F11 (may depend on window manager)</td>
<td>F11 (may depend on window manager)</td>
</tr>
</tbody>
</table>

### Zoom Text Smaller

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom Text Smaller</td>
<td>Ctrl+- (minus sign)</td>
<td>Cmd+- (minus sign)</td>
<td>Ctrl+- (minus sign)</td>
</tr>
</tbody>
</table>

### Zoom Text Larger

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom Text Larger</td>
<td>Ctrl+= (plus sign)</td>
<td>Cmd+= (plus sign)</td>
<td>Ctrl+= (plus sign)</td>
</tr>
</tbody>
</table>

### No Zoom (back to normal/100%)

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Zoom (back to normal/100%)</td>
<td>Ctrl+0</td>
<td>Cmd+0</td>
<td>Ctrl+0</td>
</tr>
</tbody>
</table>

### View Page Information

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Page Information</td>
<td>Ctrl+I</td>
<td>Cmd+I</td>
<td>Ctrl+I</td>
</tr>
</tbody>
</table>

### View Page Source

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Page Source</td>
<td>Ctrl+U</td>
<td>Cmd+U</td>
<td>Ctrl+U</td>
</tr>
</tbody>
</table>
### Tabbed Browsing Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Navigator Tab</td>
<td>Ctrl+T</td>
<td>Cmd+T</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Switch to Next Tab (when using Tabbed Browsing with more than one tab)</td>
<td>Ctrl+Tab or Ctrl+Page Down</td>
<td>Ctrl+Page Down</td>
<td>Ctrl+Tab or Ctrl+Page Down</td>
</tr>
<tr>
<td>Switch to Previous Tab (when using Tabbed Browsing with more than one tab)</td>
<td>Ctrl+Shift+Tab or Ctrl+Page Up</td>
<td>Ctrl+Page Up</td>
<td>Ctrl+Page Up</td>
</tr>
<tr>
<td>Close Tab (Close window if one page open)</td>
<td>Ctrl+W</td>
<td>Cmd+W</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Open link in new foreground tab</td>
<td>Insert</td>
<td>Insert</td>
<td>Insert</td>
</tr>
<tr>
<td>Open link in new background tab</td>
<td>Shift+Insert</td>
<td>Shift+Insert</td>
<td>Shift+Insert</td>
</tr>
</tbody>
</table>

### Sidebar Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open/Close Sidebar (toggle)</td>
<td>F9</td>
<td>F9</td>
<td>F9</td>
</tr>
<tr>
<td>Switch to Next Sidebar Panel</td>
<td>Alt+Page Down</td>
<td>Option+Page Down</td>
<td>Alt+Page Down</td>
</tr>
<tr>
<td>Switch to Previous Sidebar Panel</td>
<td>Alt+Page Up</td>
<td>Option+Page Up</td>
<td>Alt+Page Up</td>
</tr>
</tbody>
</table>

### Forms Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to Next/Previous Item in Form</td>
<td>Tab/Shift+Tab</td>
<td>Tab/Shift+Tab</td>
<td>Tab/Shift+Tab</td>
</tr>
<tr>
<td>Submit Form</td>
<td>Enter</td>
<td>Enter</td>
<td>Enter</td>
</tr>
<tr>
<td>Press Selected Button / Select Radio Button</td>
<td>Space</td>
<td>Space</td>
<td>Space</td>
</tr>
<tr>
<td>Select an Item from a List</td>
<td>Up Arrow, Down Arrow, or First Letter of Item Name</td>
<td>Up Arrow, Down Arrow, or First Letter of Item Name</td>
<td>Up Arrow, Down Arrow, or First Letter of Item Name</td>
</tr>
<tr>
<td>Check/Uncheck Checkbox (toggle)</td>
<td>Space</td>
<td>Space</td>
<td>Space</td>
</tr>
<tr>
<td>Open a Drop-Down Menu</td>
<td>Alt+Down Arrow</td>
<td>Option+Down Arrow</td>
<td>Alt+Down Arrow</td>
</tr>
</tbody>
</table>
## Mail & Newsgroups Shortcuts

These shortcuts are available from Mail & Newsgroups windows.

### General Mail & Newsgroups Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to Next Mail Pane (Folder, QuickSearch, Thread, Message Panes)</td>
<td>F6</td>
<td>F6</td>
<td>F6</td>
</tr>
<tr>
<td>New Message</td>
<td>Ctrl+M</td>
<td>Cmd+Shift+M</td>
<td>Ctrl+M</td>
</tr>
</tbody>
</table>

### Message List Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Message as File</td>
<td>Ctrl+S</td>
<td>Cmd+S</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Open Message (in a new window)</td>
<td>Ctrl+O</td>
<td>Cmd+O</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Delete Message</td>
<td>Del</td>
<td>Del</td>
<td>Del</td>
</tr>
<tr>
<td>Undo Delete Message</td>
<td>Ctrl+Z</td>
<td>Cmd+Z</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Select All Messages</td>
<td>Ctrl+A</td>
<td>Cmd+A</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Collapse All Threads</td>
<td>\ (backslash key)</td>
<td>\ (backslash key)</td>
<td>\ (backslash key)</td>
</tr>
<tr>
<td>Expand All Threads</td>
<td>* (asterisk key)</td>
<td>* (asterisk key)</td>
<td>* (asterisk key)</td>
</tr>
<tr>
<td>Message Source</td>
<td>Ctrl+U</td>
<td>Cmd+U</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Go to Next Message</td>
<td>F</td>
<td>F</td>
<td>F</td>
</tr>
<tr>
<td>Go to Next Unread Message</td>
<td>N</td>
<td>N</td>
<td>N</td>
</tr>
<tr>
<td>Go to Next Unread Thread</td>
<td>T</td>
<td>T</td>
<td>T</td>
</tr>
<tr>
<td>Go to Previous Message</td>
<td>B</td>
<td>B</td>
<td>B</td>
</tr>
<tr>
<td>Go to Previous Unread Message</td>
<td>P</td>
<td>P</td>
<td>P</td>
</tr>
<tr>
<td>Reply to Message (replies only to sender)</td>
<td>Ctrl+R</td>
<td>Cmd+R</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Reply to All in Message (replies to sender and to other email addresses in message)</td>
<td>Ctrl+Shift+R</td>
<td>Cmd+Shift+R</td>
<td>Ctrl+Shift+R</td>
</tr>
<tr>
<td>Forward Message</td>
<td>Ctrl+L</td>
<td>Cmd+L</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Edit as New (compose new email using the body and attachments of the selected message)</td>
<td>Ctrl+E</td>
<td>Cmd+E</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Mark Message as Read</td>
<td>M</td>
<td>M</td>
<td>M</td>
</tr>
<tr>
<td>Mark Thread as Read</td>
<td>R</td>
<td>R</td>
<td>R</td>
</tr>
<tr>
<td>Mark All Messages in Selected Folder as Read</td>
<td>Ctrl+Shift+C</td>
<td>Cmd+Shift+C</td>
<td>Ctrl+Shift+C</td>
</tr>
</tbody>
</table>
## MESSAGE COMPOSE SHORTCUTS

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send Message Now</td>
<td>Ctrl+Enter</td>
<td>Cmd+Enter</td>
<td>Ctrl+Enter</td>
</tr>
<tr>
<td>Send Message Later</td>
<td>Ctrl+Shift+Enter</td>
<td>Cmd+Shift+Enter</td>
<td>Ctrl+Shift+Enter</td>
</tr>
</tbody>
</table>

## COMPOSER SHORTCUTS

These shortcuts are available from Composer windows.

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Page</td>
<td>Ctrl+S</td>
<td>Cmd+S</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Open File</td>
<td>Ctrl+O</td>
<td>Cmd+O</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Close Page</td>
<td>Ctrl+W</td>
<td>Cmd+W</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Find in Page</td>
<td>Ctrl+F</td>
<td>Cmd+F</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Find Again</td>
<td>Ctrl+G</td>
<td>Cmd+G</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Insert/Edit Link</td>
<td>Ctrl+L</td>
<td>Cmd+L</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Increase Indent</td>
<td>Ctrl+[</td>
<td>Cmd+[</td>
<td>Ctrl+[</td>
</tr>
<tr>
<td>Decrease Indent</td>
<td>Ctrl+]</td>
<td>Cmd+]</td>
<td>Ctrl+]</td>
</tr>
<tr>
<td>Discontinue Text Styles</td>
<td>Ctrl+Shift+T</td>
<td>Cmd+Shift+T</td>
<td>Ctrl+Shift+T</td>
</tr>
<tr>
<td>Discontinue Link</td>
<td>Ctrl+Shift+K</td>
<td>Cmd+Shift+K</td>
<td>Ctrl+Shift+K</td>
</tr>
<tr>
<td>Select Row/Column</td>
<td>Ctrl+Drag</td>
<td>Cmd+Drag</td>
<td>Ctrl+Drag</td>
</tr>
<tr>
<td>Select Cells(s)</td>
<td>Ctrl+Click (drag to select block of cells, or continue clicking to select individual cells)</td>
<td>Cmd+Click (drag to select block of cells, or continue clicking to select individual cells)</td>
<td>Ctrl+Click (drag to select block of cells, or continue clicking to select individual cells)</td>
</tr>
<tr>
<td>Decrease Font Size</td>
<td>Ctrl+- (minus sign)</td>
<td>Cmd+- (minus sign)</td>
<td>Ctrl+- (minus sign)</td>
</tr>
<tr>
<td>Increase Font Size</td>
<td>Ctrl+=(equal sign)</td>
<td>Cmd+=(equal sign)</td>
<td>Ctrl+=(equal sign)</td>
</tr>
<tr>
<td>Text Style Bold</td>
<td>Ctrl+B</td>
<td>Cmd+B</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Text Style Italic</td>
<td>Ctrl+I</td>
<td>Cmd+I</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Text Style Underline</td>
<td>Ctrl+U</td>
<td>Cmd+U</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Text Style Fixed Width</td>
<td>Ctrl+T</td>
<td>Cmd+T</td>
<td>Ctrl+T</td>
</tr>
</tbody>
</table>
**HELP WINDOW SHORTCUTS**

These shortcuts are available from Help windows.

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Help and Support Center within Navigator, Mail &amp; Newsgroups, Composer, and Address Book</td>
<td>F1</td>
<td>Help Key</td>
<td>F1</td>
</tr>
<tr>
<td>Navigate Links within Content Pane (right pane)</td>
<td>Tab</td>
<td>Tab</td>
<td>Tab</td>
</tr>
<tr>
<td>Switch between Content Pane and Search/Contents/Index/Glossary (toggle)</td>
<td>F6</td>
<td>F6</td>
<td>F6</td>
</tr>
<tr>
<td>Navigate Index Terms (while Index Pane is selected)</td>
<td>Up/Down Arrow</td>
<td>Up/Down Arrow</td>
<td>Up/Down Arrow</td>
</tr>
<tr>
<td>Scroll Pane (Content, Table of Contents, or Index)</td>
<td>Up/Down Arrow</td>
<td>Up/Down Arrow</td>
<td>Up/Down Arrow</td>
</tr>
<tr>
<td>Expand/Collapse Table of Contents Tree Structure</td>
<td>Left/Right Arrow</td>
<td>Left/Right Arrow</td>
<td>Left/Right Arrow</td>
</tr>
<tr>
<td>Print Page</td>
<td>Ctrl+P</td>
<td>Cmd+P</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Go Back to Previous Page</td>
<td>Alt+Left Arrow Key</td>
<td>Alt+Left Arrow Key</td>
<td>Alt+Left Arrow Key</td>
</tr>
<tr>
<td>Go Forward One Page</td>
<td>Alt+Right Arrow Key</td>
<td>Alt+Right Arrow Key</td>
<td>Alt+Right Arrow Key</td>
</tr>
</tbody>
</table>
Alphabetical Index

Address Book 33
Address Button 35
Address card 34
Block unwanted popups 9
Bookmark 4
Bookmark Manager 18
Bookmarklets 39
Bookmarks 10
Card 34
Caret browsing 14
Component bar 1, 2
Compose mail 22
Composer 36
Custom Keywords 10, 17
Distribution lists 33
False positives 32
Filter 28
Filters 28
Find links as you type 14
Find text as you type 14
Form Manager 15
Formatting Toolbar 23
Free Mozilla Software 5
Help 3
Images 8
Junk icon 31
Junk Mail Controls 29, 30
Keyboard Shortcuts 41
Label 26
Location bar 1, 2
Mail window 20
Mail window layout 21
Manage Bookmarks 17
MapQuest 11
Master password 16
Menu Bar 1, 2
Message (compose) 22
Message composition window 22
Message filter 26
Message filters 28
Message folders 27
Message list 20
Message views 25
Navigation Toolbar 1, 2
Password Manager 16
Personal address books 33
Personal toolbar 1, 2
Pop-unders 9
Popup Manager 9
Popups 9
Preferences 26
Print Preview 7
Printer properties 7
Resize large images 8
Resize text 12
Save an image as a file 8
Searching 6
Sidebar 1, 2, 11
Sidebar handle 1, 2
Smileys 23
Spam 29
Spell 24
Status bar 1, 2
Sub-folders 10
Tab Bar 1, 2
Tabbed browsing 4
Tabs (multiple windows) 1, 2
Text Re-Sizing 12
Theme 5
Themes 13, 38
Web sites 38